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System requirements

The following information refers only to the program versions 2021 to 2025. In older versions, 
some details and handling were different in places.

The system requirements are very low. All that is required is a standard Windows™ PC/laptop or, 
if necessary, a Windows server (as a file server or terminal server).

System requirements

 Windows™ 11, 10, 8, 7, or Server/Enterprise versions, 64 bit

 Computer with Intel™ (x64) or AMD™ processor (AMD64), not for Arm™ CPUs
 Hard disk: 42 MB for program installation, plus own input data
 Screen resolution at least 800 x 600 pixels, higher recommended
 PDF viewer (any, for tutorial and self-created reports)
 optionally: for a signature pad the software "eSignatureSuite" (StepOver.com)

 Data folder: full access in the assigned data folder (see pages about data folder),
no use in Dropbox™ and comparable cloud services.

 No dependencies on frameworks, .NET, browser, Internet, Office, Access or similar.
 does not require access to the Internet, even when entering a license code.

Can be used locally at a single workstation without installation

Starting  with  program  version  2024,  the  program  can  also  be  started  and  used  without 
installation. This option is mainly intended for trying out the demo version (without license code). 
If you use the program permanently, you should install it, e.g. to be able to define a common data 
folder on a file server (Shared Folder), so that several users can use the program simultaneously 
with the same data.

Secure download 

For security reasons, download the program only from our web domains aidex-software.com or 
keyorganizer.org via https. When starting the program, make sure that Windows displays "Aidex 
GmbH" as the publisher. The name of the signature provider can also be read in the file properties 
before starting the program. This signature is the only way to ensure that the downloaded file has 
not been modified, i.e. manipulated or infected.

Next pages: FAQ ∙ Installation ∙ Data folder
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FAQ and technical details

Key Organizer also on Mac or Linux?

With WINE you can also run the Key Organizer program under Linux. For Mac OS X there is a 
commercial Wine offshoot called CrossOver. 

Which database is used by the Key Organizer?

The program uses files to store the input data. These files act as a database. For use by several 
simultaneous users, the program locks individual records that are currently being processed. 

Therefore, you do not need any SQL database or Access installation or other additional programs. 
Thus, you will also not incur any additional license costs, no maintenance effort for third-party 
software and no incompatibilities - and the Key Organizer can be used on any common Windows 
PC with almost no installation effort.  In addition, we can guarantee that you will  never have 
version conflicts with our file database and that you will not have to worry about them. 

In order to remain master of your own input data, e.g. in case of a future change, the program 
offers export options to .CSV and Excel.

The message "Record is being edited by other user" appears.

If this message is displayed without a comprehensible reason, i.e. the user named there is not 
logged into the program at all, the write protection of the data record reserved for him must be 
cancelled manually. The cause may be, for example, an unreachable network connection or an 
unforeseen program termination.

A simple method is that the named user logs into the program again on the previously used PC 
and edits the data record in question again. After that, the lock should be removed.

The second option is to remove the whole lock file (will be regenerated automatically). To do this, 
call the data folder of the Key Organizer in the file explorer. You can find the path in the program 
by pressing F2 (or via menu: Info > Info and Contact).
Then quit the Key Organizer and delete the file "Data.wpi" in the data folder (should be only 1 kb 
in size). After that the data set can be edited again.
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Installation

You can find the function to install in the program in the main menu under: 
File > Install program.

During the installation you can only specify the program folder, but not yet change the data folder. 
This can be done in a separate step after installation, see next page: Data folder.

During the installation, Windows administrator rights are requested if the usual programs system 
folder is to be installed and an uninstall entry is to be created. The suggested default path is: C:
\Program Files\KeyOrganizer\

The "Program files (x86)" folder is suggested if a 32-bit version of Key Organizer (up to version 
2019) is already installed in it.

The target directory may be chosen at will. Even an installation e.g. on a USB stick would be 
possible.

Distribution in the local network

In case of desired distribution in your computer network: There is no Silent Option, however, the 
program is freely movable, i.e. you can unpack it with the installation function first into any folder  
(for this purpose icon links and uninstall entry can be switched off) and then distribute the entire,  
unpacked folder manually to one or more locations. It is best to enter the desired, common data 
path in the "KeyOrganizer.ini" file (DataPath=...) before distribution.
For the users you can create an icon shortcut on Start.exe.

Instead of distributing to clients, we recommend that you simply make the unpacked program 
available centrally on a file server. No connected drive is required on the client, accessibility via 
UNC path is sufficient.

By the way, even without a license code you can already test the network capability and multi-
user capability. When purchasing a license code, it is then sufficient to enter the code once on any 
client. There is no need to perform a new installation. The activation is stored in the shared data 
folder.

Next page: Data folder

4



Data folder

Since the Key Organizer stores the input data in files, a file folder is required as a data folder. 
Please take care of the backup of the data folder.

In case of local installation (or local use without installation), the program version 2021 uses the 
APPDATA folder provided by Windows for this purpose, located in the user directory, by default in:

new       C:\ProgramData\[username]\KeyOrganizer\Data\

If an old program version up to 2019 has already been found on the PC, the existing folder will 
continue to be used if necessary, by default in:

alt       C:\Program Files (x86)\KeyOrganizer\Data\

You can read the path actually used by the started program in the program by means of the F2 
key (or via menu: Info > Info and Contact) in the info window.

Off to the server! (Shared Folder)

If a file server with Windows folder sharing is available, to which all users of this program have 
access, we recommend moving the data folder to the server. We also recommend this with regard 
to data backup, i.e. the data folder must be included in the server's backup run.
Multiple users are allowed to access the same data folder at the same time.
 
Set the new path to the new data folder you have chosen in the KeyOrganizer.ini configuration file 
located in the program folder of the installed program.

DataPath=X:\Folder\Data\

or 

DataPath=\Server\Folder\Data\

or

DataPath=Data\       (as a relative path for direct subfolders, relative to the .ini file).

When moving, always move the entire Data folder with all the files and subfolders it contains. Do 
not leave a copy at the original location so that there is no confusion and different data statuses 
later. Experience has shown that users do not notice at first that they are working on different 
data sets.

Next page:
Data folder requirements
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Data folder requirements

The Key Organizer performs extensive file operations in the data folder, i.e. not only reading and 
writing  data  files,  but  also  automatically  creates  year  subfolders  in  the  data  folder,  creates 
temporary files, deletes them or renames them as needed. Therefore, simple write permissions in 
the data folder are unfortunately not sufficient.

Access rights for the data folder

The data folder must have "full control" permissions for all users who will use the Key Organizer. 
In addition, the inheritance of rights to subfolders must be enabled.

Within the program interface, the Key Organizer regulates the powers of its users through its own 
user settings, e.g. in which program areas the user may enter changes or whether he may print 
lists and create data exports.

Windows user account

Please note that each user of the Key Organizer must be logged into Windows with a different 
Windows user name. This has nothing to do with licensing, but is technically necessary to reserve 
individual data sets for processing by a specific user.

No Dropbox® or comparable cloud services!

In case of simultaneous use by several users, the program depends on being able to lock data 
files for a short time, so that all users always read only the latest version of a file and make 
changes in it. Otherwise, there is a risk of losing the last change made by another user.

With cloud-based services, such as Dropbox, synchronization is time-delayed. In particular, due to 
the presence of local file copies, the locking mechanism of the Key Organizer no longer works, 
because it unknowingly locks only one local file copy, while all other users may continue to read 
and write their local copies - and possibly with outdated data statuses. The version conflicts lead 
to partial data loss and record confusion due to duplicate IDs. You do not want that.

If you can ensure that there is only one user working on a dataset in the cloud at the same time,  
you can use the program at your own risk if you enable the "Saving without .bak file" option in the 
settings.
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Data backup

Please include the data folder of the Key Organizer in your data backup. The current data path can 
be read in the program, see page: Data folder.

We recommend that you place the Key Organizer's data folder on a file server and then use the 
server's backup function there.

Please backup the entire Data folder including all files and subfolders. 

A small backup function was integrated in the program versions up to 2019, but this is no longer 
offered as it no longer meets current requirements.

Multiple databases

Most customers get by with one database for key management if they have a contiguous company 
site  whose keys are  managed centrally.  On the one hand,  it  is  intended that  the entire  key 
management is stored centrally (this is also perceived as advantageous by the customers), and on 
the other hand, the database is designed in such a way that up to 200 master key systems for 
any number of buildings can be stored. 

However,  multiple  databases  make  sense  if,  for  example,  a  chain  store  is  to  maintain  an 
independent  database for  each store on a central  server.  Then create a data folder  for  each 
branch, e.g. \Server\KeyOrganizer\Branch1\

You can offer the users a store-dependent program shortcut to start, so that the Key Organizer is 
called directly with the correct database. The command line are for example like this:
[Program Folder]\Start.exe "DataPath=\Server\KeyOrganizer\Branch1\"

The databases are completely independent of each other, i.e. in each database there is its own 
user administration and e.g. also its own employee master (the key recipients).
Unfortunately, a combination of several databases, e.g. with overlapping employee master, is not 
yet possible. Furthermore, it is also not possible to subsequently merge the databases into one.

In terms of licensing, nothing changes as a result of the storage locations, i.e. it is still necessary 
to purchase a main license for each legally independent company - and to take into account the 
number of PC workstations in each case.
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User permissions

The Key Organizer contains a program-internal user administration, in which each user can define 
and change his own password. In the user administration it can be defined which user has which 
rights in the program, i.e. which program functions he is allowed to execute.

After the installation, no users are created yet. As long as this remains so, anyone who has access 
to the program can log in without a password. At the latest when working with real data in the 
program, you should create one or more user names and set passwords.

You can find the user management in the Key Organizer in the main menu: Edit > Users.

Also create user accounts for  vacation and sick leave replacements,  as this  will  allow you to 
distinguish later in the change log who actually made a change.

After you have entered and saved a user, you can use the "Permissions" button to define the 
user's rights.

Only those users who have activated the right for "Users + user rights" are allowed to change 
user rights and passwords of other users. The program makes sure that you cannot lock yourself 
out by automatically giving special rights to remaining users if necessary.

If an important password is lost and cannot be replaced even by another user, please contact the 
software manufacturer (info@aidex-software.com) to request the appropriate master password for 
your program version.
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Data import

We would like to save you the effort of entering your data manually (or at least reduce it) and 
have therefore equipped the Key Organizer with various import functions, especially for Excel lists.
You can find the import functions in the program via the main menu: File > Import.

For lists, e.g. key lists or employee lists, you can use the "Individual Import", where you can 
configure the columns of your table individually.

For locking plans (cross tables with a locking matrix) please use the "Import Excel locking plan" 
function instead. Please adjust the columns in your Excel table beforehand as shown in the sample 
locking plan that we offer on the download page of our website.

For a locking system of more recent date, you can usually obtain the locking plan from the locking 
system manufacturer  or  your supplier  as an Excel  table.  Alternatively,  the file  types .kwd (a 
special locking system file format) or .xml can be used. However, with .kwd and .xml we cannot 
guarantee that the data import will  work due to various format differences,  so we ultimately 
recommend Excel tables.

Submit files for review

Since the structure of existing data or files can be very different, we offer you the possibility to  
send us your files free of charge and without obligation - even before you purchase the software - 
so that we can check the data for importability and offer you assistance.

Therefore, please send us your existing files (locking plans, lists, spreadsheets) informally by e-
mail. We will then check free of charge and without obligation whether and how the data can be  
imported into Key Organizer.

Data updates

The import functions are primarily intended for a one-time import, i.e. subsequent changes are 
maintained  manually  directly  in  Key  Organizer.  However,  for  larger  companies  with  many 
employees,  it  makes  sense  to  regularly  perform a  comparison  with  the  employee list  of  the 
personnel administration. There is a special function for this, which is described on the next page.
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Importing a key transfer list

Many customers have already maintained their own key handover list as an Excel spreadsheet 
before they purchased Key Organizer. A suitable table can be read into the program using an 
import function ...

Main menu: File > Import > Import key issuances

Key Copy no.
Locking 
system Qty. Recipient Department No. issued on returned Remark

101 5 System1 1 Smith, Maria Administration 1044 11/02/2019

102 8 System1 1 Smith, Maria Administration 1045 04/02/2020

GS1 3 System1 1 Smith, Paul Administration 1046 07/05/2021 02/01/2022

The table may only contain one key and one person per line. If a person has received several keys  
or a key has been issued to several persons, a separate row must be created for each.

The columns "Key", "Recipient" (person) and "issued on" (issue date) are mandatory! If you do 
not know the date of issue, you must enter a fictitious date, e.g. 01/01/2020 (has a recognition 
value as a fictitious date).

The table must be sorted by the issue date in ascending order!

The column "Copy no." can be omitted if you do not use consecutive numbers for your keys.

The column "Locking system" can be omitted if all keys belong to the same locking system. You 
must then select the locking system in the import window instead.

The "Qty." column can be omitted if exactly 1 key was always transferred per line.

The columns "Departments" and "No." (personnel number or similar) are optional and can be used 
if new persons are created in the program by this import, in which case this additional information 
should simply already be imported.

If a named key or person has not been entered in the program before, a new entry will be created 
by the import. If there is already an entry with the same name in the program, the transfer is  
applied to this existing entry. It is important to note that the spelling of the name in the program 
and in the table must be identical, because even a missing hyphen or similar is sufficient for the 
import to create a new entry instead, which may result in unwanted duplicate entries.

Load your table into the import window. You have to select the used columns there manually. Also 
select the date format displayed and the target locking system.

Import the transfer table only once, because otherwise the transfers will be executed repeatedly 
(multiple times). The import cannot be undone. You should therefore try out the import first as a 
precaution by switching to Sandbox mode beforehand.
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Regular import of a
current list of persons

If you manage your employees with a software, you can possibly have the data maintained there 
regularly read into the Key Organizer in order to automatically keep the list of persons in the Key 
Organizer up-to-date.
 

The prerequisite for this is that your employee administration can export a simple table with the 
names of the employees, preferably as a CSV/text file with tab as separator.
 

In order to automate the data transfer as far as possible, the Key Organizer knows certain call 
parameters that cause the Key Organizer to read in the table.

Call via command line

The command line call for the Key Organizer is something like this ...

KeyOrganizer.exe multistart autoLogin=XXX "autoImport=C:\Path\PersonalImport.ipo" 

"DataFile=\Server\DataFolder\Data.ada"

You can find your personal autoLogin parameter in the Key Organizer on the "Settings" window, 
accessible via the menu: Edit > Settings > Other.
Note that the autoLogin parameter is bound to a user and changes as soon as the password of 
this user is changed.

The autoImport parameter points to an .IPO file (contains import settings), which we will gladly 
provide on request! (E-Mail: info@aidex-software.com)
Use the autoImport parameter to specify where you saved the IPO file.  The quotation marks 
surrounding  the  entire  expression  are  mandatory  if  there  might  be  a  space  in  the  path 
specification.

After  the  import  run  (takes  between  a  few seconds  and  several  minutes,  depending  on  the 
number of people), the program closes automatically.

Error log

In the event that an error occurs during import, the Key Organizer can keep a log file so that you 
can locate the error.
 

If necessary, enter the following line manually in the KeyOrganizer.ini  file in the Key Organizer 
program directory:

ErrorLogFile=[path\]filename.txt

But successful imports can also be logged ...

SuccessLogFile=[path\]filename.txt

You may specify the same file for ErrorLogFile and SuccessLogFile if you want to collect all logging 
in one file.
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Licensing

The first license, i.e. what is marked in the price list e.g. with variant 1000 etc., is valid for one PC 
workstation. On this PC one or more users may use the Key Organizer, but the program may not 
be used on another PC.

If the Key Organizer is to be used on additional PCs, an additional license must be purchased 
starting with the second PC. We offer these additional licenses at a very reasonable price.

The same applies to use by means of a terminal server. Here, the number of terminals/client PCs 
on which the program is expected to be accessed must be counted accordingly. If this question 
cannot be answered unambiguously, the number of Key Organizer users must be counted as an 
alternative - assuming that nowadays most users have their own workstation PC available.

Only for vacation replacements or special assignments, e.g. for the first data entry on a separate 
PC, no additional license needs to be purchased.

Example: The full-time employees A and B should use the Key Organizer regularly on their PCs. 
Employee C is a temp and uses B's PC as well. The vacation replacements are done by employee 
D in the office next door. Employee E recorded all data on his laptop in advance.
In this example, only the PCs of A and B are counted, although the Key Organizer is also installed 
or available on the computers of D and E.
This means that in addition to the main license (e.g. program variant 2500), an additional user 
license must be purchased for the second PC.

A fixed price applies to the additional user license - regardless of which variant was purchased as 
the main license.

In the case of chain stores where the branch offices are legally independent, each branch office 
must purchase its own main license, i.e. the discounted additional licenses cannot be purchased 
for other companies. In exceptional cases, a deviating written agreement can be made.

Finally, we would like to mention that the majority of our customers find the one-time prices for  
the Key Organizer pleasantly favorable. Especially the additional user licenses are available at 
pocket money prices, so to speak. Our software does not include any "call home" monitoring or 
license key query. All the more we would be pleased if you would also treat us fairly and purchase 
additional licenses from us if needed. Thank you very much!
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Program updates

The Key Organizer will be regularly expanded again starting in 2021. In addition to improvements, 
new functions will also be added that have been requested by our customers. 

If you have a user license for the program version from 2021 or higher, you can simply always 
download the latest available version from our website. Simply install the current version over the 
existing installation. The input data and your license will be retained.

The functional scope of the Key Organizer depends on the purchase date of the usage license. The 
usage license itself is time unlimited, i.e. the existing program can be used further without an 
update purchase.
If a newer version is downloaded from the website and installed, the existing license code can 
activate the functions known to it, but not the new functions added later.

If  you  are  interested  in  a  new  function  after  the  12-month  update  period  has  expired,  for 
example, you can purchase an additional update year if you wish. The costs for this are approx. 
25% of the new purchase price. If you are interested, please ask us!
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Delete database

After trying the demo version of the program and making a few test entries, sometimes there is a 
desire to delete the entire database with all the test entries again, and then start from scratch.

For security reasons,  the database can only be deleted manually.  To do this,  we recommend 
deleting all contents from the data folder (see below for how to do this). 

To be deleted:

- all master data (persons, doors, keys, locking systems, etc.)
- the log history and the change log
- saved handover receipts (PDFs)
- Stored signatures
- all program users and their permission settings
- all edited print templates
- the multi-client selection (directory list)
- License code

An existing license code remains valid, but must be re-entered into the program after deleting the 
database.

Performing the deletion:
Start the Key Organizer and log in. Click in the main menu on: Edit > Settings. 
In the Settings window, go to "Files" and click the "Open" button at "Data Folder". An explorer 
window will then appear showing the files in the data folder. Leave the explorer window open, but 
in Key Organizer close the settings window and the whole Key Organizer program.

Check the data folder to make sure that it does not contain files that are not part of the program, 
e.g. manually saved Excel import files or similar that you may still need. Likewise perhaps transfer 
receipts from the subfolder "Documents".

Instead of actually deleting files and subfolders, you can  move  them to another location (for 
backup), because the deletion cannot be undone.

Remove  all  subfolders  and  individual  files  from  the  data  folder,  e.g.  the  "TimeTravel"  and 
"Documents" subfolders, and all files such as "Data.ada", "Log2025.alg" and others.

Ideally, the data folder itself is still present afterwards, but is completely empty.

When you start the Key Organizer again, no more entries are available. If you received a license 
code during purchase, please enter the license code again in the program (Menu: Info > License 
code).
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Signature Pad

The Key Organizer as of version 2021 generates handover receipts as PDF documents. These can 
be digitally signed with a signature pad.

Recommendation: Pads and software from StepOver GmbH, Germany (stepover.com)
See: https://www.aidex.de/software/key-organizer/signatur-pad.html
Pad manufacturer StepOver offers the "eSignatureOffice" software for its pads, which takes care 
of the actual signing process and embedding the signature in a PDF. 

The Key Organizer automatically finds an installed eSignatureOffice software by its registry entry 
if it is installed on the same computer. 
The Key Organizer then automatically offers its user the option to sign when a receipt is printed. 
The search for the eSignatureOffice is activated by default in the settings of the Key Organizer.

Work faster: a control file for automation

In StepOver "eSignatureOffice" program you can save settings as a control file. It is very practical  
that the program can find the right place in the PDF where the signature should be. To do this,  
you define a term that appears in front of the signature line in the PDF. In the Key Organizer print  
templates it is the word "Signature:" by default.

In the eSignatureOffice menu: Tools > Create signature set

Save the file in the suggested SignatureSets folder with the name "KeyOrganizer.sss". This file 
name and location is important, see below.

In the first settings window, simply click Apply. In the following window, create a new search 
term, e.g. "Signature:". Then determine the offset so that the area for signing is on the right 
above the search term (thus on the signature line in the document).

If  the  above  mentioned  file  "KeyOrganizer.sss"  exists,  the  Key  Organizer  passes  it  as  start 
parameter to the eSignatureOffice. Only then the user can start signing immediately. Otherwise he 
always has to draw a signature field with the mouse first.

Pads in the network 

If the eSignatureOffice software runs on a server, but the pad is connected to a client PC, the 
distance can be bridged with a tool called "TCP Client" or "TCP Extension" (both names refer to the 
same tool).
Please contact StepOver directly and ask for conditions regarding server licenses.
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Print templates

Since version 2022-08 we recommend to use Word files (.docx or .rtf) as print templates, because 
Word documents can be customized by the users themselves. However, Key Organizer can only 
use Word files if Microsoft Word is also installed on the PC. Unfortunately it does not work with 
other programs yet, e.g. not with OpenOffice/LibreOffice.

If Microsoft Word is not available, you have to use templates in HTML format as an alternative, for  
which Key Organizer does not need an additional program. The disadvantage of the HTML format 
is  that  the users  themselves  usually  do not  have HTML knowledge and are therefore  mostly 
dependent on help from the IT department, if templates are to be adapted.

The program comes with ready-made templates that are used by default, both in Word and HTML 
format.

The templates can be accessed via the main menu: Edit > Edit print templates. 

In addition, you get the option "Edit template" directly in the print window after calling a desired 
print function.

For each template type, select that you want to use Word (not default).

The placeholders that can be used are listed on the following web page:
https://www.keyorganizer.org/en/placeholders.html

HTML alternative

An edited HTML template is not saved as a file, but directly in the database. If an edited template  
is to be copied from a file or from Sandbox mode into the active database, this can only be done 
by copy & paste of the HTML text.

Insert a logo: Copy your company logo as a graphic file into the data folder of the Key Organizer. 
This is necessary so that every program user has access to the file. The data folder is displayed in  
the program by pressing F2. 

It is advantageous if the graphic file is not too huge. In the HTML templates you will find an HTML 
tag <!image ...>, where you can specify the file name. You can also specify the desired print 
width of your logo in millimeters. The height matching this width will be calculated automatically 
internally.

If you have any questions, please contact: info@aidex-software.com
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Data Privacy

The Key Organizer application stores input data locally in a file-based format within a designated 
folder. The software does not transmit any data over the internet or to third parties. It can be fully 
disconnected from the internet, for example, via Windows Firewall settings.

The Key Organizer does not transmit any input data to the software developer and does not grant 
the developer any access to such data. Therefore, Aidex GmbH does not act as a data processor, 
and no data processing agreement (DPA) is  required — whether under the EU General  Data 
Protection Regulation (GDPR), the California Consumer Privacy Act (CCPA), or any comparable 
U.S. contractual data protection framework.

You,  as the operator of  the software and the party responsible for  processing personal  data, 
should establish a clear internal usage policy for employees to ensure privacy-compliant use of the 
application, and implement appropriate organizational measures to safeguard personal data.

Restricting File Access

Access to the program’s data files must be effectively limited to the necessary group of users by 
applying Windows file access permissions. Based on our experience, most companies typically 
assign  key  management  responsibilities  to  only  a  few employees  — often  just  two per  site. 
Therefore, the number of users requiring access to the program can usually be kept to a small and 
manageable group.

The stored input data is not readable in plain text within the storage files; however, the files are  
currently not encrypted according to modern encryption standards. Strong encryption is planned 
for implementation during the course of 2025.

Since all storage files are located within a single data directory used by the application, your IT 
department can restrict access permissions for this folder to authorized personnel only — as part 
of your organization’s internal access control concept.

Data Minimization

When collecting personal data, the principle of data minimization should be taken into account. 
For recording a key handover to an individual, it is sufficient to identify the person by name or, for  
example,  by  an  employee  ID  number.  Therefore,  the  Key Organizer  only  requires  a  simple 
designation of the person. No additional personal information is required by the software.

It is also not necessary to enter all employees into the system — only those who are currently 
assigned as key holders need to be recorded.
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Data protection: 
Deleting personal data

According to the requirements of data protection, a person has the right to have his/her personal 
data deleted when there is no longer a reason for storing it. With regard to the key management 
program, this occurs when, for example, a person has returned all  the keys issued, no more 
searches or the like are required, and the person is not to receive keys again on a regular basis or 
in the near future. 

A complete deletion is opposed by the wish of e.g. audit departments that there should be a 
complete and gapless logging of all key handovers. 
The Key Organizer records all key movements in monthly log files, which can extend over many 
years  since  the  start  of  program use.  These  log  files  also  contain  at  least  the  name of  the 
respective key owner. 

Deleting a person in the Key Organizer is done in two steps. First, the person is only archived via 
the Delete button, i.e. the entry is still present, but is hidden. The person can then still be found 
using the search function on the log tab. In practice, we once had a case in which, after a theft  
had been discovered, the access possibilities of the previous week had to be reconstructed.

If necessary, the person entry can be reactivated and made visible again, e.g. if the person should 
receive a key again after all. This function can be found by right-clicking in the person list, menu 
item "Display deleted entries".

When the time has come to finally delete the data of a person, e.g. according to a company-
internal  requirement  according to  GDPR,  the function "Destroy entry  permanently"  should  be 
used, which can also be found by right-clicking on the list of persons.
This function searches all logs and destroys all personal data of the selected person finally and 
irrevocably. 
In the log for  the keys that the person formerly had in his possession, only the information 
"(deleted)" is then displayed as the former key owner.

The  program has  no  access  to  data  backups  that  are  regularly  created  by  a  server  in  your 
company network, for example, i.e. the deleted personal data can still be contained in backups. 
This  problem  can  be  solved  only  by  deleting  old  backups  regularly.  Usually  this  is  done 
automatically by regularly replacing older backups with more recent ones.
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